Delays on the Transporeon platform (Monday, 2026-03-16)

Incident Report for Transporeon

Postmortem

On Monday, March 16, 2026, at approximately 13:20 CET, the Transporeon platform experienced processing delays resulting from an accumulation of events within internal distribution queues. Technical analysis identified the root cause as degraded performance of the messaging broker database under peak load conditions.

System remediation was successfully achieved following a database optimization at 15:30 CET, which restored standard performance levels. By 17:40 CET, all backlogged queues were fully processed, and the platform returned to normal operational status.

To mitigate future occurrences, we have implemented enhanced preventive measures to bolster system resilience against high-load scenarios.

We sincerely apologize for any disruption this may have caused and appreciate your understanding.

Posted Mar 20, 2026 - 15:59 CET

Resolved

The incident affecting delays on the Transporeon platform has been fully resolved, and the data has been duly reprocessed. You can proceed working on the platform as usual.

We understand how critical our services are to your daily operations, as well as to your users, partners, and customers. We sincerely apologize for any disruption this incident may have caused to your business operations and appreciate your patience.

Should you require additional information or support, please reach out to us at https://support.transporeon.com.
We are happy to assist you.
Posted Mar 16, 2026 - 17:40 CET

Monitoring

A period of stability has been observed, and data reprocessing is still underway and proceeding as expected, so the incident state is currently under "monitoring."

We would like to inform that some customers may experience delayed results when using the global search tool during this time. You can still search for data manually by applying filters to the respective columns.

We will provide a further update as soon as the remaining data is fully reprocessed.
If you require immediate assistance, please contact our Support team at https://support.transporeon.com.

We appreciate your understanding and sincerely apologize for any inconvenience caused.
Posted Mar 16, 2026 - 16:43 CET

Identified

The root cause of the incident that caused delays on the Transporeon platform has been identified and fixed as of 15:30 CET, March 16, 2026 (same day).

Please allow us some time for final data reprocessing.

We will post a separate notification here as soon as all data reprocessing is complete.

We appreciate your understanding and sincerely apologize for any inconvenience caused.
Should you require additional information or support, please reach out to us via https://support.transporeon.com, and we will be glad to assist you.
Posted Mar 16, 2026 - 15:50 CET

Investigating

Some customers may be experiencing delays while working on the Transporeon platform today, Monday, March 16, 2026, starting at approximately 13:20 CET.

We are aware of the issue and are currently investigating it with the highest priority. We will send further updates as our engineers make progress towards a resolution.

Our current recommendation is to wait until our engineers restore the currently delayed data transmission. Data remains intact and no loss has been observed.

Please expect the next update within the next hour.

If you require immediate assistance, please contact our Support team at https://support.transporeon.com.

We sincerely apologize for the inconvenience and reassure you of our determination to resolve this issue promptly and accurately.
Posted Mar 16, 2026 - 14:33 CET
This incident affected: Data transmission, Transport Assignment, and Time Slot Management.