Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2024 - 18:00 CET
Scheduled
We will be running maintenance of our Help Center Support system today, November 20th, 2024 at 18:00 CET.
You can continue working on Transporeon Platform without interruptions during this time.
We expect a short interruption by way of which access to the support portal, or to your open requests will not be temporarily possible. If you encounter issues with accessing support, please wait and check again later. In the meantime, you can reach us via phone.
Posted Nov 20, 2024 - 12:10 CET
This scheduled maintenance affected: Support Services.