Database issue
Incident Report for Transporeon
Postmortem

On Tuesday 29.11.2022 at 19:13 CET we faced an unexpected database issue while performing our standard database maintenance. We immediately tasked our database team to investigate this issue.

Our services continued being reachable with minor interruptions. The progress of our investigation was recorded on the status page with each need-to-know update.

During this time our support functions in Americas and Asia time zones were supporting customers at the expected level of responsiveness and support. After the successful resolution, we continued monitoring the situation closely, as well as check and resend all failed, stalled, or delayed data transfers from the time window of the incident.

We apologize for the inconvenience caused.

Posted Dec 01, 2022 - 15:26 CET

Resolved
Currently we can confirm the situation is back to normal and you should no longer be affected by the incident.
We took care to resend all stalled or delayed data.
We continue monitoring the situation and establishing the root cause, which will be detailed shortly in the postmortem report.
We once again apologize for the inconvenience and remain at your availability for further support.
Posted Nov 30, 2022 - 10:12 CET
Update
We have resolved the issue and monitor the situation closely, until we can fully confirm it is permanently fixed.
We apologize for the inconvenience.
Posted Nov 30, 2022 - 07:30 CET
Update
We regret to inform you that errors may still occur.
We pay utmost attention to resolving them.
Posted Nov 30, 2022 - 01:43 CET
Update
Update: We performed an update of our services to restore the database connection and rebuilding of index. We continue monitoring the situation, until we can confirm it is permanently fixed. We apologize for the inconvenience.
Posted Nov 29, 2022 - 23:09 CET
Identified
Dear Customers,

On Tuesday 29.11.2022 at 19:20 CET we faced a short-timed database issue. We recognized the issue immediately and proceeded to restart the process and rebuild the index.
As a result, within a short timeframe of approximately 1 hour, the transfer of some data messages was stalled or delayed. Please be reassured that if you were affected by this, we will proceed to resending the missing data. Else you can continue working as before without any expected interruptions.
Should you encounter any issue or need additional insights, please reach out via https://support.transporeon.com.
We reassure you of our continued support and apologize for the inconvenience.
Posted Nov 29, 2022 - 21:55 CET
This incident affected: Data transmission.